Botpress removing Intents because of invalid JSON?

I am so confused. Everytime I create a new intent and try to put multiple utterances, botpress deletes them (after the 10th intent or so) and log shows

09:44:09.995 Mod[nlu] An error occured while loading fax-view-received.json [Error, Could not parse intent properties (invalid JSON, enable NLU errors for more information).

I’ve never had this error before. Why does it keep doing this with every intent (note I tried UI and creating utterances through back end in intents folder and both give same result). Please help me, I keep adding intents and botpress just erases all the work.

First, what version of botpress are you running (please try to always include it in your questions).

Can you please share the failing intent file (could be in DM )

Version: 12.1.3.

The error came from adding too many intents within a short time frame through the botpress UI. It seemed that Botpress couldn’t take all that processing at once, since there were 20 utterances created for one intent within 1 minute, and it crashed.

It deleted the intent because it added two additional brackets that were not needed (see below).

To sum it up: Either have patience and wait for bot to retrain each utterance or right all your utterances in the back end and then let the bot retrain all of them at once. PATIENCE

You’re right, you have to be patient a little when using the UI. Fortunately that patience won’t be necessary for so long. In the next patch (12.1.4) we run training and webservers on 2 different processes so you won’t have to wait all the training to be done to continue editing your intents. We also have a all new intent editor coming in 12.2.0. that allows batch import as simple as copy/paste.

Until then, you’ll have to use a bit more of your patience :frowning: