Botpress with https using apache2

I have configured a chatbot with bot on a test page (Test bot1) and it’s working fine without https.
I have configured apache config file and botpress config file botpress.config.json to use https
In apache conf file:

ProxyPass /botpress http://www.eventic.ovh:3000/botpress
ProxyPassReverse /botpress http://www.eventic.ovh:3000

And botpress.config.json:

{
  "$schema": "../botpress.config.schema.json",
  "httpServer": {
    "host": "www.eventic.ovh",
    "port": 3000,
    "backlog": 0,
    "bodyLimit": "10mb",
    "cors": {
      "enabled": true
    },
    "externalUrl": "https://www.eventic.ovh/botpress",
    "session": {
      "enabled": true,
      "maxAge": "1h"
    },

When I load Test bot1 it seems to work, the chat opens, but when I write something words do not show on the chat window neither response of botpress.
If i reload the test page words I typed before and botpress response appear on the chat window.
Something is wrong in the configuration I guess but I don’t know what.
Thanks for your help.

Pascal

Hie @Pascol thank you for reaching out. I faced the same issue myself and resolve it by removing websocket from the socketTransports array as below. Please try that out and let me know

{
  "$schema": "../botpress.config.schema.json",
  "httpServer": {
    "host": "localhost",
    "port": 3000,
    "backlog": 0,
    "bodyLimit": "10mb",
    "cors": {
      "enabled": true
    },
    "externalUrl": "",
    "session": {
      "enabled": false,
      "maxAge": "1h"
    },
    "socketTransports": [
      //remove "websocket",
      "polling"
    ],

Thanks a lot Michael, it works!