Cannot get /auth/login

Hi Everyone,

New to botpress here, and I tried using the MacOS binary as well as a docker-compose file (prefer this method), but I’m getting stuck with the same error with both startup options?

Upon running the binary from the download package this is what I get:

And in the browser:
(removed print as I’m a new user) I get a blank page with “Cannot GET /auth/login”

It tries to load assets but seems to fail… Console has an error about A bad HTTP response code (404) was received when fetching the script. which I believe is from /auth/login… (I get redirected to this endpoint when I access http://localhost:3000)

I’ve looked around here and google but havent found anything? Thanks!

Hey @roynasser ! I just downloaded the Mac OS binary from the website.
After extracting the archive, I ran ./bp from the extracted folder, starting the server.

When I open up my browser to localhost:3000, I am automatically redirected to localhost:3000/admin/register:

Can you reach that page just after starting the server?

Also, when I reach /auth/login, I get the same error as you (Cannot GET /auth/login)

I have not tried the docker-compose method yet.

that worked!! Thanks!