Creating a web chat plugin

Hi, I am trying to create a plugin for web chat. I have followed the instructions given in the recipe-docs and also managed to look at the plugin hosted in github.
After trying quite a bit, I am having no other option but bother you guys for help :slight_smile: . I tried creating a simple select plugin but I am not able to see it getting loaded in the webchat window. I tweaked the webpack config to do lite build, but that didn’t help either. I am not seeing any error messages in the log that could help me.
Could you please help me out. If I could have a reference working implementation of a webchat plugin, it would help me…

@sundarcodes Can you share your repository?

Thanks for asking. Here is the link to github repo
I am trying to get my react select plugin to get displayed in the web chat.
Thanks in advance for spending your time on this.

I tried to install too, but I am NOT seeing any UI changes or error messages in the logs as well.

  • 2018-10-08 22:40:52info: Loaded botpress-webchat-plugin-select, version 1.0.0
  • 2018-10-08 22:40:52info: Loaded botpress-dialog-sessions, version 1.0.0

Need some help with the WebChat extensions… I can’t push the react UI components to the web channel.

@sundarcodes , it seems there was an issue with webchat extensions. It’s fixed in botpress 10.47.0 that we’ve just released. Could you check whether things work for you on it?

Having the same issue on v10.50

Unable to get web extensions working :frowning:

My code is here -

Please anyone help me on this. If possible let me know the exact step by step flow of how to get it working.


Also, getting this error in browser console

Error rendering plugin Error: Subview “Entry” doesn’t exist for module “my-module”
at n.value (module.jsx:72)
at module.jsx:36
at e.exports (_invoke.js:5)
at m.(anonymous function) (http://localhost:3000/js/commons.2ebb49e1880e81fd4326.js?a13624db5b4ca22c0de3:29:57530)
at Number.g (task.js:21)
at MessagePort.

same error with ver12… i was able to see some custom components but after addiing date component lost all of them
Please help is there any solution for this

What do you mean by you lost all of them after adding date component? Can you post a list of steps to replicate your issue?