Error with yarn build

Hi,

Why i can’t build custom component?
This is log from cmd:
X:\botpress-master\modules\custom-component>yarn && yarn build
yarn install v1.22.5
[1/4] Resolving packages…
[2/4] Fetching packages…
[3/4] Linking dependencies…
warning " > react-select@2.4.4" has unmet peer dependency “react@^15.3.0 || ^16.0.0”.
warning " > react-select@2.4.4" has unmet peer dependency “react-dom@^15.3.0 || ^16.0.0”.
warning “react-select > react-input-autosize@2.2.2” has unmet peer dependency “react@^0.14.9 || ^15.3.0 || ^16.0.0-rc || ^16.0”.
warning “react-select > react-transition-group@2.9.0” has unmet peer dependency “react@>=15.0.0”.
warning “react-select > react-transition-group@2.9.0” has unmet peer dependency “react-dom@>=15.0.0”.
[4/4] Building fresh packages…

Done in 5.83s.
yarn run v1.22.5
$ node …/…/build/module-builder/bin/entry build
internal/modules/cjs/loader.js:883
throw err;
^

Error: Cannot find module ‘X:\botpress-master\build\module-builder\bin\entry’
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:880:15)
at Function.Module._load (internal/modules/cjs/loader.js:725:27)
at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:72:12)
at internal/main/run_main_module.js:17:47 {
code: ‘MODULE_NOT_FOUND’,
requireStack: []
}
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

Ok i resolve this problem :slight_smile:

Hey Michal,
How did you resolve the problem? I have the same error when trying to build with a botpress binary installation (not source code directly).

Hi @kpritzelhentley, if you downloaded the binaries you just have to run botpress.

To build (yarn && yarn build) you need to download botpress sources as indicated here.

I hope it helps,
Have a great day.