Installation from windows 10 no joy

Using the bp.exe file in the windows installation files did start off the extraction process but once it ended it does not appear to have worked. I try going to http://localhost:3000/ does not bring up the registration page as per your guide.

Im not a developer but techy enough I hoped to be able to install this.

There was no mention of having to install Node.js but I have as well in case that is needed.

Could you please advise me of what to do next.

Trying the install again doesn’t work.

Many thanks.
Daniel

Hi,

Just in case, have you run the extracted executable (bp.exe) by double clicking it?

Can you send us the console output you had when starting botpress? You might had an error. If so knowing the error details will help us diagnose your problem.

François

Hi Francois, yes I ran the extracted bp.exe and it was extracting fine. I did see some lines saying that the folder could not be renamed and was being moved elswhere. I didn’t see the rest of the script finish.

Now when I run the bp.exe I just a line for a folder which is empty.
See attachment.

I really wanted to give Botpress a go and see if we could use it in our community, not a great start.

Thanks for your help in installing, but in case it doesnt work, how do I uninstall what was installed in case I want to not go with your solution, I don’t like the idea of a server being added and not accessible anymore. I may have to uninstall to install it another way?

Thanks
Danielexe

There’s no installation. All you need to do to uninstall is delete de binary executable.

It’s unfortunate that the binary has not worked from your first try. Maybe @allardy has an idea of what is wrong?

In all cases, thanks for trying out our product! If ever you decide not to go with Botpress, we wish you the best of luck with our competitor’s platforms.

François

@dreamfactoryuk We work hard to provide a seamless experience for users with different OS but there may be some issues here and there, but we’ll be happy to help you resolve them quickly.

When you start Botpress, it only unzip its files and starts the server. There is no service registered, nothing placed in program files, etc.

I am running it on Windows 10 without issue. If you double click on bp.exe and it closes shortly after, then there was an exception which caused the window to be closed. Please follow the next steps so the window stays open after the error, so you can provide the full logs of what happened:

  1. Download a fresh binary
  2. Open the command line (press Window+R, then type “cmd”)
  3. Move to the folder where you extracted Botpress (cd “yourfolder”)
  4. Type “bp.exe” and enter

Thanks for your help @allardy .

I followed your steps so I could see what the errors were, and appeared to be a write issue, so I turned off all my firewall software during install and it worked fine.
thanks again.

2 Likes

@dreamfactoryuk Thanks for the information, really appreciated! Could you tell me where the write issue happened ?

When you start it up for the first time, we decompress module zip files to a cache folder (located under botpress/modules/.cache).

There also is a small directory where we store informations which may be used by different instances of botpress (you see the location as App Data Dir when it is started up).

One issue I had on windows was a painfully slow extraction process, since the antivirus was scanning every single files, and there’s a lot of them


I’ve copied the entire extraction process here so you can view where the issues occurred.

Hope that helps. A note about firewall might be easiest workaround. Thanks!

Thanks a lot @dreamfactoryuk ! Yeah, we’ll definitely add that to the documentation. Let us know if you run into any other issue !

@dreamfactoryuk I also run Botpress locally on Windows 10 as well as on our Windows 2012 Servers. So if you run into any additional issues, post here and I will do my best to share my experiences. A couple of tricks here and there but due to Windows specifics. Botpress itself seems to be doing its stuff great. :slight_smile:

2 Likes

HI @dreamfactoryuk ,

Maybe this can help