Issues with Heroku

Hi, I’m having issues when deploying to Heroku.

Firstly, when using the One Click installer, it has this command to run by default:

web /bin/sh -c ./duckling\ \&\ ./bp

This means that once the app loads and i visit mysite.herokuapp.com, it takes me to the duckling response that says “quack!”. I want to be taken to the development studio.

I also tried installing it using the method listed here but I keep getting ECONNREFUSED errors too, and cant create bots at all.

Could someone please help me out? Its getting very frustating

Hello @jackd, botpress push a new Heroku button (In the Readme.md). But we still have the issue with the ECONNREFUSED. At least the studio will be up, But it didn’t resolve the Duckling problem :frowning:

One thing you can do is the following example

Solution

You need to create a Heroku Application first

$ docker run -p 3000:3000 --rm -it -d botpress/server:latest /bin/sh -s "./bp & ./duckling"
$ heroku container:push web -a NAME_OF_YOUR_HEROKU_APPLICATION
$ heroku container:release web -a NAME_OF_YOUR_HEROKU_APPLICATION

Hi @Daehli,

I followed this documentation as the official documentation for setting up botpress with heroku misses the steps to enable the external DB (as far as I can see those two steps are the only different ones) - if not done this way, the container crashes upon start.

After getting it running however bots created won’t mount:
image

I am using the latest release (12.26.3).

Is it the same issue/ or do I have to do any other step not mentioned in both of the setup tutorials?

Thanks for your help!
-matt-schu

We created a Heroku application using this

$ docker run -p 3000:3000 --rm -it -d botpress/server:latest /bin/sh -s “./bp & ./duckling”
$ heroku container:push web -a NAME_OF_YOUR_HEROKU_APPLICATION
$ heroku container:release web -a NAME_OF_YOUR_HEROKU_APPLICATION

I am unable to access the studio using the Heroku URL. The heroku app url points to “Quack” .

I also see something weird. I get an error saying thet heroku is unable to reach the duckling server. ( see image below) but still I see that the duckling URL is enabled and local.

Please help us resolve this issue!