Language Server not working on Digital Ocean Droplet

Hello everyone! I’m Jordi and I’m making a videogame in which you can talk to characters using botpress.

I managed to build a bot for the game locally, now I want to deploy it online so I can release the game. I went for the digital ocean droplet option, loaded my bot and QnAs and flows and everything without trouble but… the language server is set to lang:3100 so the NLU is not working.

image

I tried editing the nlu.json from the Botpress code editor but is doesn’t change anything. Can someone help me? What I’m supposed to do?

Thanks!

Hi @GreyShock,

can you send us screenshots of the exact errors you’re facing?

Thanks

François

Sure!


(hi-res: https://imgur.com/ENA875J)

It’s a fresh droplet in digital ocean, isn’t it suppose to come with a working lang server? I don’t know how to change environment variables in digital ocean, I managed to build a working bot both locally and on heroku, but can’t figure out how to edit this one.

Thank you!!

Allright, I believe your lang server works just fine, you just dont have any language loaded yet.

You have downloaded models for language English on your file system, but you have not loaded it in memory.

To do so, just click on the “Load” button right next to “English” and then it should work as expected!

François

The thing is that I already tried clicking on it, waits for a couple of seconds, then it shows the load button again.

Path for language server should not be lang:3100 right? Is that something that works?

For what I gathered I’m not the only one experiencing this issue: https://www.digitalocean.com/community/questions/trouble-loading-default-installed-language-in-botpress

Solved it.

My droplet didn’t have enough RAM to run the language server. Had to upgrade from 2Gb to 4Gb of RAM.

Hope this helps to anyone with the same issue!

3 Likes

Hey @GreyShock!

Really sorry, I forgot to answer you… I didnt visit the forum much in the last few days.

I’m glad you found out! Yes it does happened from time to time that lang server crashes because my computer is missing memory.

Many thanks again for your contribution!

François

It also depends how many languages and how many dimensions those have (default is currently 100dim, but there is also 25dim and 300dim available, see https://botpress-public.nyc3.digitaloceanspaces.com/embeddings/index.json )

@GreyShock @frank_levasseur
Created a feature request with my related story: https://github.com/botpress/botpress/issues/4185

1 Like

Thx, I will answer directly on your gh issue

1 Like