NLU and flow wide transition not working

Please I am new and surprised that a node I have, which I linked by flow-wide transition is not working. I have tried several times, viewed several youtube guides, still same, Please I need help. Will not mind a remote help… I use teamviewer

Hi @spec-ng,

I will need a lot more information to help you with this… Have you tried using your debugger to see what happens with your message? Is there any errors in the logs?

Hi @frank_levasseur

Please I cannot see any error n the log, I really need help, I dont know what am doing wrong and why the bot is not picking intent.

Please help. If we can schedule a time on friday for remote assistance please.

Thank you


Please there is no error in the log, Please help me

Hey @spec-ng, there won’t be any remote assistance on my side, other than replying on this forum.

From what I see, your bot understands the intention ‘create-account’. Is this what you expect?

If not, what do you expect? Can I see all of your intents?

Also, I noticed your are using an old version of botpress. You should take a look at newer versions, we release fairly often.

Regards,

François


Dear @frank_levasseur

I did a flow-wide transition to 4 different flows, based on various intents, it recognizes the intent on the debugger, but it does not navigate to that flow on the chat, rather it starts all over again.

Regarding the version, I actually have the latest version, but I was thinking that it might be a bug that is why I moved back to the older version.

I will send the intent screenshot in the next email.

Thank you


Dear @frank_levasseur
Below is the other intents created.

If you can create a simple bot for that have ability to recognise intents and navigate to the flows/nodes. Will greatly appreciate.

Hi again,

I’m not familiar at all with flow wide transitions, but I can garante you that your problem has nothing to do with the NLU.

I’m curious, why do you use flo-wide transitions instead of simply node scoped transitions?

I’ll try to find some information and get back to you.

François

Hi Frank
Please I will be waiting, I just need to use the intent to direct the flow of discussion to the appropriate node

@frank_levasseur

I also noticed that for unknown reason the emulator chat box does not allow me to type again after I was able to write some intents and flows. Its strange, please any reason why this happens?

Can you send me your bot? Just paste a google drive link on this thread (or any other cloud storage provider you like)

Dear @franklevasseur

Please find the link

I just want the bot to go to any node as per the conversation or intent from the webchat

This is the new bot…I cant type in the emulator…

Hi again,

I think I found the problem:
image

Make sure agent.flow.json refers to an existing flow. The actual name you are looking for is Agent.flow.json. Same thing for merchant.flow.json which does not exist…

When I made the correction, I managed to do this:

image

This should fix your problem,

François

Thank you sir,

I am not facing issues pushing to heroku…

Please how do I solve this…

Thank you

@spec-ng

this question is unrelated to your first problem,

so please open another thread on this forum.

François