No model found for the following languages: en

Hi

I am new to Botpress. I ran into the No model found for the following languages: en error, but googled and found the page telling me to host my own language server. I followed all the steps and got my own language server running with English installed. I checked and my botpress is telling me it’s using my own hosted language server but still I keep getting this error:


Please help!

Hi, @aletia.stapelberg welcome to the forum!

Normally when you launch botpress for the first time it will use our cloud-hosted language server so you shouldn’t have to worry about this.

If you want to revert to our language server you have to change the field languageSources.endpoint to https://lang-01.botpress.io/

If you changed the configuration to run your own server (on-premise) then indeed you need to download which languages you want.

Botpress will by default search in : HOME/botpress/embeddings else, you need to specify the folder as indicated here .

I hope it helps,
Have a great day

Hello aletia.stapelberg, thanks for posting on the botpress forum. Have you include the model inside your Language server?

In the documentation, you have some example on how to install the language inside the language server.

Thanks for your reply Pierre. I tried the self hosted language server because I was getting this error when I were still pointing to the endpoint: https://lang-01.botpress.io/. So when I googled, it was the solution I got for the issue. However after following everything in the docs for getting the own server up and running the issue remained.

Thanks for your replay Daehli, I am sure it is as the documentation you linked to was the exact steps I followed.

Can you try with the default configuration (botpress language server).

After Go in your Chatbot and click Train at the Right bottom

It should resolve the issue.