Persistent Menu does not work in messenger channel

Hello , please help me .
persistent menu does not work in my bot.

Thanks.
This is my code in conf

“persistentMenu”: true,
“persistentMenuItems”: [
{
“title”: “Home”,
“type”: “nested”,
“call_to_actions”: [
{
“title”: “Pay Bill”,
“type”: “postback”,
“payload”: “PAYBILL_PAYLOAD”
},
{
“type”: “web_url”,
“title”: “Latest News”,
“url”: “https://www.messenger.com/”,
“webview_height_ratio”: “full”
}
]
},
{
“title”: “Newsletter”,
“type”: “nested”,
“call_to_actions”: [
{
“title”: “Subscribe”,
“type”: “postback”,
“webview_height_ratio”: “full”,
“payload”: “SUB_NEWSLETTER”
},
{
“type”: “web_url”,
“title”: “Unsubscribe”,
“url”: “https://www.messenger.com/”,
“webview_height_ratio”: “full”,
“payload”: “UNSUB_NEWSLETTER”
}
]
},
{
“title”: “Q&A”,
“type”: “web_url”,
“url”: “https://www.messenger.com/
}
],

Hello, I also do not get a persistent menu displayed. Have you found a solution yet?
many greetings

“persistentMenu”: [
{
“locale”: “default”,
“call_to_actions”: [
{
“title”: “My Account”,
“type”: “nested”,
“call_to_actions”: [
{
“title”: “Pay Bill”,
“type”: “postback”,
“payload”: “PAYBILL_PAYLOAD”
},
{
“type”: “web_url”,
“title”: “Latest News”,
“url”: “https://www.messenger.com/”,
“webview_height_ratio”: “full”
}
]
}
]
}
]

For sample ,
add this to your global config file of channel-messenger.json .
After adding this , you will not see immediately this menu in messengeer because facebook cache .

Thanks, the menu works now too.

1 Like

Hi.
I copy the code in channel-messenger.json (global), save but the persistent menu do not appear?
The channel is working and connect to the bot.

you need to wait bc of facebook cache !

Tanks, Maria.
Excelent, the menu is working now.
How put ice_breakers?
i try:
“ice_breakers”:[
{
“question”: “Oficina Virtual”,
“payload”: “”,
},
{
“question”: “Incidentes”,
“payload”: “”,
},
but, give me a error in sintax?
can you help me please?:

you can add like this way
{
“title”: “Pay Bill”,
“type”: “postback”,
“payload”: “PAYBILL_PAYLOAD”
}

Tans Maria…
Excelent.
Sorry… Another Question.
Y need Knex Oracle or Mysql
I execute “yarm install mysql -save” or “mpn install mysql -save” but yarn o npm not found.
I Install from Executable, not form sourde, the knezx is ok, i need install the extension.
Can you help me?
Thanks
Joe.