Q&A - 98% Confidence and "no suggestion matched"

Hi,

I’ve been fighting in the past few days with Q&A. For some strange, unknown reason, at least to me, I’m getting some strange behaviors.

On a simple flow like this one, where I’m adding a new context and wait for a question. The question matches 98%, but still “no suggestion matched”.

I don’t have any intents configured in this bot, I’ve restarted several times the server, and this keeps happening.

What am I missing here?

My Flow:

The Result:

Another attempt

Hi @danieljbento thanks for posting on the forum,

If I understand correctly you want to reply text when a QnA is triggered.

However this behaviour is the default one by botpress.
If you go in the QnA tab, add a QnA and an associated answer then botpress will do all the work for you and trigger the QnA, write the answer and return to the flow automatically.

I need to investigate more about what you tried to achieve but if the behaviour I described above is the one you want then it will be much easier for you to implement it like that.

Tell me if it helped, happy building ! :robot:

Hi Pierre, thanks for your reply.

I solved the problem with the solution given in this issue: QnA does not intercept

The chosen suggestion was being dropped to continue the flow.

1 Like