🚥 Recommended update for Botpress 12.9.0 and Above

Hey Everyone!

It came to our attention yesterday that there was a major bug with the “channel-webchat” module in Botpress, affecting versions 12.9.0 up to 12.13.0. The bug allowed multiple chat users to share the same chat window.

The team has pushed a fix yesterday afternoon and removed the affected version binaries from the Download Center. We confirm that versions below 12.9.0 are not affected and thus migration is not necessary.

If you are running Botpress 12.9.0 or above, we strongly recommend that you update your installation as soon as possible to 12.13.1. There are automatic database migrations and no manual steps necessary to benefit from this version update.

As always, before updating to the new version, make sure to make a full backup of your Botpress database.You can download the new version on our Download Center.

The changelog of everything new since version 12.9.0 can be found here: https://github.com/botpress/botpress/blob/master/CHANGELOG.md
and if you have questions or need further assistance please contact us via support@botpress.com

Thank you for understanding,
Marc

3 Likes