Unable to start language server locally (windows 10)

I am trying to run duckling and language server locally (offline mode,) and followed the documentation from botpress docs . My duckling is up , however I am not able to bring the language server up.
Based on the logs, the language server starts up but the process terminates immediately . The command window gets the control back immediately.

Steps :
downloaded bp.en.25.bin and bp.en.bpe.model and extracted it to a directory which is passed as --langDir later .

command I ran :
bp lang --offline --dim 25 --langDir <path to dir from above>

OS : window 10
Same thing happens in botpress version 12.9.x and 12.2.x

Log message on console:

E:\installed\botpress\botpress-v12-2>bp lang --offline --dim 25 --langDir dirpath

22:09:05.991 Launcher ========================================
Botpress Language Server
OS win32
========================================
22:09:05.999 Launcher authToken: disabled (anyone can query your language server)
22:09:06.006 Launcher adminToken: disabled (anyone can add, remove or change languages)
22:09:06.010 Launcher limit: disabled (no protection - anyone can query without limitation)
22:09:06.020 Launcher mode: offline (languages need to be downloaded manually from a machine with Internet access)
22:09:06.024 Launcher Serving 25 language dimensions from
22:09:06.040 Service Found Languages: en
22:09:06.043 Service Loading Embeddings for EN
22:09:06.050 API Language Server is ready at http://localhost:3100/

E:\installed\botpress\botpress-v12-2>

If I do not use --langDir , then server starts and stays up as expected. But I wont be able to use any languages.

Hi @wanderer,

Welcome to the Botpress Community!

I notice from your logs the actual language loading are missing, here’s what it should look like after API Language Server is ready:

05/25/2020 15:12:36.704 Service [EN] Took 1121ms to load 474mb into RAM (lang/bp.en.25.bin)
05/25/2020 15:12:36.765 Service [EN] Took 60ms to load 39mb into RAM (lang/bp.en.bpe.model)

Can you tell me if you set langDir relative to the botpress executable or is it an absolute path?

I tried with ./lang, with the language model and embeddings in the botpress_v12/lang folder I created in Windows 10, it started without issue.

Let me know if you resolved it in the meantime!

Happy Building :robot:

HI @wanderer,

Maybe this can help